SolusVM Patch: Rebuild Problem 'Invalid Template' Solved

Discuss our WHMCS modules and everything associated with them.

SolusVM Patch: Rebuild Problem 'Invalid Template' Solved

Postby Piotr » 23rd July 2013, 12:54 pm

Important information that we received from SolusVM support. Will be helpful for many, no doubt.
This is a solution for the problem with server rebuild returning 'Invalid Template' error.

"Here is the patch you need to run on the master node in SSH:

Code: Select all
wget http://files.soluslabs.com/solusvm/fixes/api_vserver_rebuild.txt -O /usr/local/solusvm/includes/api/api_vserver_rebuild.php

This will allow you to rebuild KVM virtual servers via the API. Example output if using the json return values would be:

Code: Select all
{"status":"success","statusmsg":"Virtual server is being rebuilt","rootpassword":"6axLkKpi","information":"Blah\nBlah\nBlah"}
"


Solution works on SolusVM beta only.
According to the answer received from SolusVM support, it will be included in the stable version.
Piotr Dołęga
ModulesGarden CMO
Website Admin
ModulesGarden - Unique Approach To Custom Software Development Services & High-End Modules
User avatar
Piotr
Site Admin
 
Posts: 615
Joined: 14th June 2012, 10:19 am
Location: Poland

Re: SolusVM Patch: Rebuild Problem 'Invalid Template' Solved

Postby dinkohrzica » 3rd September 2013, 8:23 pm

Is it only in kvm or in openvz/xen?
ty
dinkohrzica
 
Posts: 5
Joined: 3rd September 2013, 7:59 pm

Re: SolusVM Patch: Rebuild Problem 'Invalid Template' Solved

Postby Piotr » 4th September 2013, 9:17 am

It's a solution for KVM. OpenVZ/Xen don't require such a solution.
Piotr Dołęga
ModulesGarden CMO
Website Admin
ModulesGarden - Unique Approach To Custom Software Development Services & High-End Modules
User avatar
Piotr
Site Admin
 
Posts: 615
Joined: 14th June 2012, 10:19 am
Location: Poland


Return to WHMCS Modules

Who is online

Users browsing this forum: No registered users and 5 guests

cron