Proxmox VPS & Cloud Module not working [Solved]

Discuss our WHMCS modules and everything associated with them.

Proxmox VPS & Cloud Module not working [Solved]

Postby symmcom » 12th March 2014, 7:48 pm

Hello,
So far what i read it WHMCS module for Proxmox VPS and Cloud from ModuleGarden is an excellent product for what it does. I am so ready to buy both module but am unable it work. From server setup of Proxmox module in WHMCS i keep getting "Login to Proxmox Host Failed". ModuleGarden support even tried to see what causing the issue. The conclusion was that Module itself is ok, it is Proxmox server not returning something API related. I am using Proxmox 3.1. There has to be other people who has the version 3.1 Proxmox and was able to make it work. Any help from anybody?
symmcom
 
Posts: 1
Joined: 7th February 2014, 2:18 am

Re: Proxmox VPS & Cloud Module not working [Solved]

Postby apignard » 4th April 2014, 1:54 am

i have never got any issue with 3.1 & 3.2

install about 3 to 5 new promox server per week without problem at all.

just got one issue on creation but need reply to the ticket for fix it (when no more disk space in lvm)
apignard
 
Posts: 19
Joined: 27th September 2013, 4:59 pm

Re: Proxmox VPS & Cloud Module not working [Solved]

Postby godlike » 13th April 2014, 12:25 pm

I've exactly same trouble.
While pressing "Test connection", i see on Proxmox VE server:
Code: Select all
#tail -f /var/log/pveproxy/access.log
192.168.10.251 - - [13/Apr/2014:13:04:56 +0300] "POST /api2/json/access/ticket HTTP/1.1" 401 13

192.168.10.251 - is WHCMS host.
As you can see, I get 401 error - problems in authentication.
While using CURL from command line ( from example in https://pve.proxmox.com/wiki/Proxmox_VE_API#Authentification), I get it works:
Code: Select all
#tail -f /var/log/pveproxy/access.log
192.168.10.251 - - [13/Apr/2014:13:08:46 +0300] "POST /api2/json/access/ticket HTTP/1.1" 200 1080

I'm using Proxmox VE 3.2
Thanks for any help!
godlike
 
Posts: 14
Joined: 13th April 2014, 12:21 pm

Re: Proxmox VPS & Cloud Module not working [Solved]

Postby Piotr » 14th April 2014, 9:21 am

Please check your firewall settings as in the case that symmcom reported, it was causing the problem.
Piotr Dołęga
ModulesGarden CMO
Website Admin
ModulesGarden - Unique Approach To Custom Software Development Services & High-End Modules
User avatar
Piotr
Site Admin
 
Posts: 615
Joined: 14th June 2012, 10:19 am
Location: Poland

Re: Proxmox VPS & Cloud Module not working [Solved]

Postby godlike » 14th April 2014, 9:46 am

Hello!
Thanks for your reply!
Firewall is empty on both servers.
godlike
 
Posts: 14
Joined: 13th April 2014, 12:21 pm

Re: Proxmox VPS & Cloud Module not working [Solved]

Postby godlike » 14th April 2014, 10:36 am

Could you please copy auth function and Test connection API call from your PHP code here?
Or may be you have any API test procedure?
godlike
 
Posts: 14
Joined: 13th April 2014, 12:21 pm

Re: Proxmox VPS & Cloud Module not working [Solved]

Postby Piotr » 14th April 2014, 1:10 pm

There you go:

Code: Select all
if (!defined('DS'))
      define('DS', DIRECTORY_SEPARATOR);
include_once ROOTDIR . DS . 'modules' . DS . 'servers' . DS .'proxmoxVPS'.  DS .'class.API.php';

                        $API = new proxmoxVPS_API("serverip", "serverusername", "pam", "serverpassword");
                        $API->whmcsDebugMode(true);
                        if (!$API->constructor_success()) {
                              echo "Could not create PVE2_API object";
                        } else if (!$API->login()) {
                             echo  "Login to Proxmox Host failed";
                        } else {
                              echo  "Success";
                        }

If this won't help then please create a support ticket.
Piotr Dołęga
ModulesGarden CMO
Website Admin
ModulesGarden - Unique Approach To Custom Software Development Services & High-End Modules
User avatar
Piotr
Site Admin
 
Posts: 615
Joined: 14th June 2012, 10:19 am
Location: Poland


Return to WHMCS Modules

Who is online

Users browsing this forum: No registered users and 6 guests

cron